John Deere 420 hydro pump - Page 2
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 34

Thread: John Deere 420 hydro pump

  1. #11
    Senior Member
    Display Name: Andy

    Join Date
    Jan 2020
    Location
    lewiston Id
    Posts
    145
    Thanks
    0
    Thanked 11 Times in 7 Posts
    Make sure the tractor has enough hydraulic fluid.
    Place the tractor in reverse and rev engine normally. When and if it starts to move, run it backwards for awhile until it operates normally in reverse. After doing the reverse thing try the forward position,

    so is that what I need too do?
    Andrew

    1973 110,
    1972 110,
    1973 110,

    1969 112,

    1988 420,
    1981 400,

    1976 300,

    1987 160,

  2. Remove Advertisements
    WFMachines.com
    Advertisements
     

  3. #12
    Senior Member
    Display Name: Bob Meyer

    Join Date
    Feb 2002
    Location
    Athens, TN
    Posts
    1,498
    Thanks
    143
    Thanked 335 Times in 276 Posts
    Yes. Personally, to me "rev engine normally" would be no more than 1/2 throttle. Also, move outer lever (for rockshaft cylinder) until engine changes sound. Then move lever in opposite direction until engine changes sound. Once you get tractor to move, do some full right circles and then full left circles. Bob
    '80 317 w/18hp B&S and divert valve for rear hydraulics, 3 pt hitch, 5' york rake
    '82 314 w/rear PTO for tiller
    33 tiller
    49 thrower
    54 4 way blade
    Mod 48 deck & Mod 462 TracVac

  4. #13
    Senior Member
    Display Name: Andy

    Join Date
    Jan 2020
    Location
    lewiston Id
    Posts
    145
    Thanks
    0
    Thanked 11 Times in 7 Posts
    Okay I'll try it and see how it goes.
    Andrew

    1973 110,
    1972 110,
    1973 110,

    1969 112,

    1988 420,
    1981 400,

    1976 300,

    1987 160,

  5. #14
    Senior Member
    Display Name: Bob Meyer

    Join Date
    Feb 2002
    Location
    Athens, TN
    Posts
    1,498
    Thanks
    143
    Thanked 335 Times in 276 Posts
    Andy, Just to inform/enlighten you a little! The hydro does more than just propel your tractor.

    The charge pump delivers oil to 2 places, your power steering valve & the hyd valve with the levers, and then to the hyd pump (for lubrication if Fwd/Rev is in neutral). Draining the hydro oil may...or may not!... drain oil from these parts. Operating the steering and the lever pushes oil through these valves and pushes any air back into the hydro to be vented out. Also, don't be too surprised when nothing happens for a minute or so. Your filter is empty and needs to be filled with oil and nothing happens until it is full.

    Once everything works, shut engine down, wait 5 or 10 minutes, and check level. Any air that was in the system has been replaced with oil and level may be a little low. Bob
    '80 317 w/18hp B&S and divert valve for rear hydraulics, 3 pt hitch, 5' york rake
    '82 314 w/rear PTO for tiller
    33 tiller
    49 thrower
    54 4 way blade
    Mod 48 deck & Mod 462 TracVac

  6. #15
    Senior Member
    Display Name: Andy

    Join Date
    Jan 2020
    Location
    lewiston Id
    Posts
    145
    Thanks
    0
    Thanked 11 Times in 7 Posts
    Okay that makes scene I just replaced the seal that goes around my drive shaft that's why I wanted too know what I should do.
    Andrew

    1973 110,
    1972 110,
    1973 110,

    1969 112,

    1988 420,
    1981 400,

    1976 300,

    1987 160,

  7. #16
    Senior Member
    Display Name: Andy

    Join Date
    Jan 2020
    Location
    lewiston Id
    Posts
    145
    Thanks
    0
    Thanked 11 Times in 7 Posts
    I ordered the wrong filter so I'm gonna get a new one tomorrow.
    Andrew

    1973 110,
    1972 110,
    1973 110,

    1969 112,

    1988 420,
    1981 400,

    1976 300,

    1987 160,

  8. #17
    Senior Member
    Display Name: Bob Meyer

    Join Date
    Feb 2002
    Location
    Athens, TN
    Posts
    1,498
    Thanks
    143
    Thanked 335 Times in 276 Posts
    Andy, Wipe area on hydro where filter seats. Cloth is good, and paper usually leaves small fibers which can work their way into system. Do a final wipe with a CLEAN finger. Next, fill filter about 1/3 full of oil and put a small amount of oil around the gasket. Install filter...with the thoughts that some oil is going to run down your arm, as it does mine! Fill hydro and bled air per above instructions. Bob
    '80 317 w/18hp B&S and divert valve for rear hydraulics, 3 pt hitch, 5' york rake
    '82 314 w/rear PTO for tiller
    33 tiller
    49 thrower
    54 4 way blade
    Mod 48 deck & Mod 462 TracVac

  9. #18
    Senior Member
    Display Name: Andy

    Join Date
    Jan 2020
    Location
    lewiston Id
    Posts
    145
    Thanks
    0
    Thanked 11 Times in 7 Posts
    Thanks Bob I'm getting the right filter today!
    Andrew

    1973 110,
    1972 110,
    1973 110,

    1969 112,

    1988 420,
    1981 400,

    1976 300,

    1987 160,

  10. #19
    Senior Member
    Display Name: Andy

    Join Date
    Jan 2020
    Location
    lewiston Id
    Posts
    145
    Thanks
    0
    Thanked 11 Times in 7 Posts
    I put my oil filter on my 420 and filler it with oil started my tractor and used the steering (it had NO power assist) and I pushed the levers and nothing happened......and my tractor did not move for 5+ minuets...
    Andrew

    1973 110,
    1972 110,
    1973 110,

    1969 112,

    1988 420,
    1981 400,

    1976 300,

    1987 160,

  11. #20
    Senior Member
    Display Name: Bob Meyer

    Join Date
    Feb 2002
    Location
    Athens, TN
    Posts
    1,498
    Thanks
    143
    Thanked 335 Times in 276 Posts
    Could be a major or minor problem!
    Remove oil fill cap and check oil level. Cap is vented and could be clogged giving false reading.
    Loosen oil filter about 2 turns, oik should come out. If not, remove filter and fill about 1/3-1/2 full of oil. QUICKLY install filter as oil will run out!
    Start tractor, go to rear and verify shaft coming out of hydro unit is rotating.
    If you didn't have to add oil and shaft is rotating, could be a bad charge pump.

    Do a search online for TM1590 and you'll find free downloads. LOTS of good info in there. Bob
    '80 317 w/18hp B&S and divert valve for rear hydraulics, 3 pt hitch, 5' york rake
    '82 314 w/rear PTO for tiller
    33 tiller
    49 thrower
    54 4 way blade
    Mod 48 deck & Mod 462 TracVac

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •