Weekend Freedom Machines banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6,867 Posts
Discussion Starter · #1 ·
Can someone get me the width, height and thickness of the 455 radiator.

Looking at using one for another project.

Thanks
 

·
Registered
Joined
·
6,867 Posts
Discussion Starter · #4 ·
Thanks Steve.
 

·
Registered
Joined
·
10 Posts
Hello all, I'm having an issue with my '73 10hp JD 110. Recently I've had issues when mowing taller grass. The machine's deck would lose power/momentum. I tightened the cable that tensions/engages the pto coming off of the engine...moved by the pto lever. Now, when mowing taller grass the deck keeps going, the engine bogs down returning to idle. Last night I attempted to cut grass in my backyard (not very tall at all, no where near too tall) and the mower returned to idle. Would not mow, if I were to try it, the engine would essentially stall out and die. Have I over-tightened the pto cable? Governor issue? Dirty carb?
 

·
Registered
Joined
·
10,675 Posts
John I am afraid it could be any of those things. When was the last time the engine/tractor had a complete tune up. Points, condenser, carburetor adjustment, maybe carburetor cleaning, air cleaner, valve adjustment or spark plug. Hard to do repairs without touching the tractor and listening to it run. Roger
 

·
Registered
Joined
·
1,507 Posts
John,
I'd agree with Roger. A wide points setting or bad fuel delivery will do what you are describing. Throw in weak plug wire or poor plug and you've got an engine with low power.
Give it a fresh tune up and try it then.
Dom
 

·
Registered
Joined
·
1,507 Posts
So, Does that mean the cable clamp is loose or the butterfly shaft is broken? Are you missing any screws?
Try tightening the cable at the clamp and see whas up.
Dom
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top