Weekend Freedom Machines banner
1 - 12 of 12 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
The mower quit mowing well yesterday. A quick peek under the deck reveled only the center blade turning. Hmm. That would explain the poor cutting. So I pulled the belt cover off expecting to find a broken belt. Belt is worn, but not broken. However, the idler spring is in two pieces.

I got a new spring, but I'm puzzled as to where to connect the "fixed" end. It had been under one of the bolts for the left side blade spindle - but that doesn't seem right. I'm not seeing any other obvious place to hook it?

Am I missing the obvious? Where is it supposed to connect? Or does it really belong under the bolt?!?!?

-- fm
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
After a little mixup, I got part M86243 from my local, friendly dealer. The part is smaller than the picture makes it look. Anyway, it's a slick little piece. Don't even need to remove the spindle bolt to install it - it just slides under the carriage bolt.

Now once again all three blade go 'round. Life is good!
 

·
Registered
Joined
·
748 Posts
Bucky -
You've posted your question in the wrong section of the forum. A 425 is too new to be a "vintage tractor." But it is discussed under the Lawn Tractor and Late Model Garden Tractor section. You're much more likely to get a useful response there.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top